Guides and Manuals

Browser Support Requirements for TELUS Business Connect

Effective February 17, to protect your privacy and security, a change will be implemented that affects older browsers that does not support current security standards. The change will affect some older browsers and some users may be prevented from accessing their TELUS Business Connect account until they upgrade browsers.

Users of older browsers will be redirected to a web page providing information on supported browser versions, and be requested to upgrade their browser.

If your browser is not supported, the following message will appear: “Please upgrade your browser – All online products are built and tested with the latest browser technology to ensure your safety and privacy. Your browser version is not supported. Please upgrade your browser to the latest version. (Internet Explorer, Mozilla Firefox, Google Chrome, Apple Safari)”

Browser versions supported after Feb 17, 2016 for TELUS Business Connect include:

Browser Type Supported Versions after Roll-out
Google Chrome version 41 or higher
Microsoft Internet Explorer version 11 or higher
Mozilla Firefox version 37 or higher
Safari version 8 or higher
Tell us what you think It's in our nature to listen. As TELUS.com/business continues to evolve, we'd love to hear more from you.